風柳メモ

ソフトウェア・プログラミング関連の覚書が中心。

GAEで使用するDjangoのバージョンを指定しているつもりなのに警告が出る

【追記】
下記件はひとまず解決済→GAEで使用するDjangoのバージョンを指定しているつもりなのに警告が出る(続き) - 風柳メモ



いつからか、ログ上に

You are using the default Django version (0.96). The default Django version will change in an App Engine release in the near future. Please call use_library() to explicitly select a Django version. For more information see http://code.google.com/appengine/docs/python/tools/libraries.html#Django

という警告が出るようになっていたので、いくつかのアプリで

from google.appengine.dist import use_library
use_library('django', '0.96')
from google.appengine.ext.webapp import template

と明示してみたのだが、相変らず警告が出てしまう。どうしたらいいんだろう、指定方法がおかしい?

本当は

use_library('django', '1.2')

として1.2を使うべきなんだろうけど、0.96から随分変わっているようなので、どのような問題が出るのか調べるのが面倒。どうしようかなぁ…。